スコープ

変数に限らず、スコープは最小限に留めていただきたい。

上のループカウンタの話に繋がるのだが、

なんで、ループの中のループで使っているカウンタ変数jをメソッドの先頭で宣言して、気持ち悪くないんだろうか。

実装のフェーズの事しか考えていない人は、こういうコードをガンガン生産する。

もっとも長いフェーズは保守ですよ。保守。

せめて、明日の他人が、2年後の自分が、読めるコードを書くように心がけて欲しい。

私も忘れないように努力したい。

#自分のブログ見ていたら、過去のエントリでもスコープについて触れていた・・・

#まだ多いのかな、最小のスコープを心がけるよりも、メソッドの先頭で宣言した方が良いと思っている人。

int iとかint jとか・・・

ループカウンタだからって、i,j,kは許されない。(私的には)

配列のインデックスを表すならindexで良いと思う。

思わず、

i(いまいちだ)

j(自嘲しやがれ)

k(くそーすめ)

とあいうえお作文してしまうので、勘弁して欲しい。

DataRowだから、drね。っつーのも止めて欲しい。

そのdrには、どんな意味があるんだ。

サンプルに書いてあるからって、それが綺麗なコードとは限らない。

もっと名前に気を使って欲しい。

機種依存文字

IT系の掲示板ですらそうだし、mixiのコミュなんかでも多いんだけど、

Macのsafariで閲覧していると、?に変換される文字が多いなあ。

多分、項目の番号なんだろうなぁと推測して読んでるけど。

最近、機種依存文字って言葉を知っている人が少ない。

私も、もしかしたら使っている事があるかもしれませんので、気をつけないと。

それにしても、数字の1を、あえて丸付きの1で表現すると何か良い事があるのかな?

明けましておめでとうございます。

昨年はいろんな方と出会う事ができ、刺激を沢山受けることができました。

今年もいろんな方から刺激を受けつつ、各方面に対して少しくらいは刺激を与えられるような年にしたいと思います。

そんなこんなで、よろしくお願いします。